Jump to content


Photo

quantum cabo 80


  • Please log in to reply
15 replies to this topic

#1 pk911

pk911
  • Members
  • 12 posts

Posted 23 August 2012 - 07:12 PM

Has anyone seen or used or know when they are comming out. They look good on their website. I have some of the older ones now, anti reverse is going on a couple, screws have come loose and paint has worn off. But they are a workhorse for what we do down here in So. Fla. so i would like to get some feedback before I redo all my stock.
This site is the best. :thumbsu:

#2 Alan Hawk

Alan Hawk
  • Moderators
  • 99 posts

Posted 23 August 2012 - 07:50 PM

Haven't seen one in flesh yet. According to tackledirect 40 and 50 are coming Feb 2013, 60 and 80 though should be released September 2012. Feeling pretty curious myself.

#3 pk911

pk911
  • Members
  • 12 posts

Posted 23 August 2012 - 10:58 PM

Haven't seen one in flesh yet. According to tackledirect 40 and 50 are coming Feb 2013, 60 and 80 though should be released September 2012. Feeling pretty curious myself.


thanks for the update, i sent them an email regarding the release. I will post if they respond.

#4 pk911

pk911
  • Members
  • 12 posts

Posted 24 August 2012 - 10:04 PM

This is what they advised me today.
Pete,

The new models will be available around the first of the year.


Thank you for contacting us,

Quantum Service
6105 E. Apache
Tulsa, OK 74115
800-588-9030

#5 Milkman

Milkman
  • Members
  • 25 posts

Posted 30 January 2013 - 01:21 AM

Anyone managed to give one of these a good work out yet? Interested in either the Cabo or Boca 60 or 80....interested to know...

#6 Alan Hawk

Alan Hawk
  • Moderators
  • 99 posts

Posted 30 January 2013 - 06:49 AM

Limited number of 60 size has been out for about two weeks, and the 80 only became available at basspro and tackledirect a week ago, so any feedback you hear now is going to be people trying to sell them. Mine is in the mail as we speak and hopefully in a couple of months I can form an opinion.

#7 Milkman

Milkman
  • Members
  • 25 posts

Posted 30 January 2013 - 03:59 PM

Thanks Alan...too soon i guess, bt thanks for the reply - i will wait with interest!

#8 pk911

pk911
  • Members
  • 12 posts

Posted 07 February 2013 - 10:10 PM

picked up the 80 the other day and came home to load it with braid. I put 40lb backing on and spliced on 50lb braid. Line did not lay up correctly, I started the line at the top of the spool, middle and the bottom. The line went on the spool like an inverted snow cone. I tried just braid, same thing. Took it back to where I purchased it and explained it to them. They tried it as well, same thing this time with mono. There are two washers for a lack of a better term on the shaft under the spool. We removed one at a time and tried it again, same issue. Going to call Quantuum tomorrow and see what they have to say about. I was disappointed. I am hoping it was just that reel. Has anyone else have a new one and have seen the same problem, and comments using the reel is appreciated. I will wait a little while longer before I purchase them again.

Edited by pk911, 07 February 2013 - 10:23 PM.


#9 pk911

pk911
  • Members
  • 12 posts

Posted 08 February 2013 - 03:19 PM

spoke to Quantum today regarding the issue. They were aware of it happening on a 60 but not an 80. They are going to call me back next week regarding the matter. I will post what I find out.

#10 Alan Hawk

Alan Hawk
  • Moderators
  • 99 posts

Posted 08 February 2013 - 05:47 PM

Yes please. Let us know what they tell you!

#11 Milkman

Milkman
  • Members
  • 25 posts

Posted 09 February 2013 - 05:36 PM

Interesting...would like to know the outcome also pk911...thx for the info so far..

#12 Milkman

Milkman
  • Members
  • 25 posts

Posted 14 February 2013 - 03:21 PM

Any luck pk? What did Quantum say?

#13 pk911

pk911
  • Members
  • 12 posts

Posted 17 February 2013 - 10:57 AM

Any luck pk? What did Quantum say?

So far no luck. They do not know what is causing the problem. It may be an anomaly but the engineers are looking into it. They have called me several times to discuss the issue and they are calling bps where I purchases the reel to determine the manufacturing batch that was sent to them. I hope they get it corrected soon and I will keep you all posted.

#14 pk911

pk911
  • Members
  • 12 posts

Posted 23 February 2013 - 08:13 PM

well it appears we have gotten to the bottom of it. When setting the spool on the shaft there are two very subtle hitches, for lack of a better term, on the shaft. If you stop at the first hitch and tighten the drag, the spool does not spool up correctly. Turn the spool a litte more and it drops down further on the shaft setting itself. It is very subtle. On the bottom of the spool where the cut outs are, it has to be down below the top of the rotor and then you know it is down all the way. The staff at BPS figured it out.  So tomorrow I go out and jig over a couple wrecks as see how it performs. Glad it was not something major.



#15 Milkman

Milkman
  • Members
  • 25 posts

Posted 24 February 2013 - 01:31 AM

Thanks pk, let us know how the reel goes with your jigging mission! Best of luck! Are you targeting AJ's?

#16 pk911

pk911
  • Members
  • 12 posts

Posted 25 February 2013 - 05:19 PM

Thanks pk, let us know how the reel goes with your jigging mission! Best of luck! Are you targeting AJ's?

it has been slow for me down here so anything on the end of the line is welcome. I will post how the reel handles as soon as I catch something.  They do seem solid as a rock tho.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users